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Custom Screens 

The Custom Screens feature allows you to create your own custom screens. People-Trak 

provides a very large number of fields to track information in all of the modules. In each 

module, these fields have been arranged into screens that are based on a general category of 

the information. For example, personal fields have been grouped on the Personal screen, 

status fields have been grouped on the Status screen, compensation fields have been grouped 

on the Compensation screen, etc.  

These groupings, though logical, do not necessarily reflect the way in which you work or the 

way in which work flows through your organization. For example, to perform a standard new 

hire process or termination, you must enter information on a number of different screens. If 

you wish to have a simpler screen dedicated to new hires or termination, it can be made with 

the Custom Screens feature. 

The Custom Screens feature in People-Trak allows you to create concise and task-specific 

data entry screens called custom screens. The custom screens are developed to reflect how the 

work or information actually flows through your organization. Well-designed custom screens 

can even emulate the various forms that circulate through your organization. When data entry 

custom screens match the forms, data entry is faster, more efficient, and less prone to error. It 

also makes it quite easy to utilize outside labor since a data entry clerk need only understand 

the specific custom screen and not the entire product. 

Once created and activated, custom screens can be incorporated into multiple-screen 

workflows or used as simple workflows all by themselves. Once the custom screen is added 

to a workflow, it can be accessed when that workflow is open. 

The Custom Screen feature in People-Trak takes advantage of the parameter-driven design of 

People-Trak. When you place a field on a custom screen it takes on all of the data entry 

attributes that apply to that field when it appears in its regular place on the standard screens. 

If the field is a date field, it will be supported by the Select Date popup. If the field is 

supported by a table, it will be supported by that same table in the custom screen. The same 

applies for the formatting, casing, length, and other attributes of the field. 

The custom screens respond to field customization exactly like the standard data entry 

screens. If you change a field name or support data or other attribute, that change is 

immediately reflected in any custom screen that uses that field. 

Custom screens are not designed to replace the standard data entry screens, but to supplement 

them. Custom screens can contain any number of different fields from any of the various 

screens from within the module. These screens can also contain several other object types. 

Once you have the objects specified, you can use the Preview feature to easily design the 

layout of your screen. You can move, size and edit objects while in preview mode. 

Custom screens can be used to add new records from scratch or to modify existing 

information. They are powerful and flexible. Custom screens are not permanent. If you create 

a custom screen and it later needs to be changed, you can modify the custom screen to meet 

your evolving needs. 
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The Custom Screens screen provides a list of the current custom screens on the left and a data 

entry area to the right. A Menu Bar and a Tool Bar are provided to enable you to fully 

manage your list of custom screens.  

Details 

Details for a custom screen include naming the custom screen, assigning it to a category and 

defining the screen type. 

Objects 

The following are object types available to use on a custom screen. Descriptions for each 

object ype are also defined.  

Button 
 Used for placing a button on the screen that will then execute the specified button trigger 

when clicked. 

Heading 1     
Used to place a heading on the screen with a colored background. In the default People-Trak 

style, this heading is in 14-point text with a background of the dark color associated with the 

selected color scheme. 

Heading 2   
 Used to place a heading on the screen with a colored background. In the default People-Trak 

style, this heading is in 12-point text with a background of the dark color associated with the 

selected color scheme. 

Heading 3      
Used to place a heading on the screen with a transparent background. In the default People-

Trak style, this heading is in 14-point text. 

Heading 4      
Used to place a heading on the screen with a transparent background. In the default People-

Trak style, this heading is in 12-point text. 

Field     
 Used for placing actual fields on the screen. 

Frame    
 Used to place and name a frame around fields in order to group them on the screen. Field 

object rows that follow the Frame object row will be placed in the frame. When a grid object 

is selected, fields from that grid are defaulted as field object rows that are displayed vertically 

inside the frame. 

Grid     
Used to place a grid on the screen. Field object rows that follow the Grid object row will be 

placed in the grid. When a grid is added and you select the grid name in the Object Name 

field, all fields in that grid are automatically added in the rows that follow the grid. You can 

then choose to delete one or more of the fields and/or rearrange the fields. 

 

Note: You cannot mix fields from different grids in one grid on the custom screen. 
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HTMLabel     
 Used to place formatted HTML label text on the screen in order to provide directions or 

added information. This object is edited with the HTML Editor and uses a style sheet for its 

formatting (specified in Desktop Setup). 

Hyperlink     
Used to place a hyperlink on the screen, which uses a button trigger to perform the actions. 

Label      
Used to place non-formatted label text on the screen in order to provide directions or added 

information. This object is edited with the Simple Editor. 

Line     
Used to place a line on the screen. 

Picture    
Used to place a picture on the screen, with an optional button trigger to perform actions.  

Screen      
Used for placing a button on the screen that will then display the specified screen when 

clicked.  

Note: Screens may only be nested in this way up to seven levels deep. For example, the 

Personal screen has a button that displays the Dependents screen, which has a button that 

displays the Dependents Address screen. This example is three levels deep. 

Defining and Updating Object Properties 

You can update an object’s properties in either the main Custom Screens screen or preview 

mode. On the main screen, highlight the object in the grid and then click the Properties 

button. In preview mode, select the object and then press F1. Both of these methods display 

the Object Properties screen for the selected object. Each object type has its own unique 

Object Properties screen with the object properties that pertain to that object. The following is 

the Object Properties screen for a field object:  

This is the most complex Object Properties screen. The following are field descriptions for all 

fields that can be on an Object Properties screen. The actual name of the field will vary 

slightly based upon the object properties screen on which it is being displayed. Several of 

these fields are also available on the main Custom Screens screen.   

Object Type  
The type of object. This field is for display only. 

Object Name  
The name of the object. This field is only used with the Button, Field, Grid, Hyperlink, 

Picture and Screen object types, and is supported by a popup based on the object type chosen. 

The Button, Hyperlink and Picture object types can all select button triggers; the only 

difference in these three objects is the presentation of the button on the screen itself.  

 

For Grid objects, it is important to use the popup to select the grid name because this 

information is necessary when doing any update field actions within triggers. After entering 
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the grid name, all fields in that grid are automatically added in the rows that follow the grid. 

You can then choose to delete one or more of the fields and/or rearrange the fields. 

Caption  
For all objects except Picture, this is the caption to display for the object on the screen. The 

Picture object has a Select File popup that allows you to select the jpg or bmp file you want to 

place on the screen; after the picture file is chosen and preview mode has been accessed, this 

Caption field will have the text ‘<Picture Attached>’ rather than the path to the image. 

Note: The following Left, Top, Width and Height fields are in pixels. 

Left  
Allows you to move the object’s location horizontally on the screen. The reference point for 

this value is the left-most side of the object. 

Top  
Allows you to edit the object’s location vertically on the screen. The reference point for this 

value is the top side of the object. 

Note: When adding certain objects to a Custom Screen, you may notice that the Left and Top 

fields are set to -1. This lets the system know that these coordinates need to be calculated. 

This calculation will happen when first going into preview mode or when saving. 

Width  
Allows you to adjust the width of the object. When you increase the width, the right side of 

the object will move to the right. When you decrease the width, the right side of the object 

will move to the left. 

Height  
Allows you to adjust the height of object. When you increase the height, the bottom of the 

object will move downward. When you decrease the height, the bottom of the object will 

move upward. 

Modifier  
For a Field object, this is the row modifier of the field and is supported by the Select Row 

Modifier popup. For a Grid object, this is the number of rows in the grid, including the 

caption row. This field is not used with the other object types. 

Note: The Select Row Modifier popup screen shows codes 1-10, but higher row numbers can 

be manually entered as well. The popup also allows you to use “+” to access the last row on 

the grid, New 1 to insert a new top row and New + to insert a new bottom row. Non-grid 

fields can only have a row modifier of blank or 1. 

Display Only  
A check box that allows you to specify whether or not the field is display only on this custom 

screen. Select the check box to make the field display only. Clear the check box to make the 

field editable. If the Required check box is selected, you cannot select this check box. This 

field is only used with the Field object type. Derived fields are for display only. 

Required  
A check box that allows you to specify whether or not an entry in this field is required on this 

custom screen. Select the check box to make the field required. Clear the check box to make 
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the field not required. If the Display Only check box is selected, you cannot select this check 

box. This field is only used with the Field object type. 

Field Settings 

The following properties are only applicable for Field objects and are only shown when 

editing the properties of a Field object. 

Note: The following Caption Left, Caption Top and Caption Width fields are in pixels. 

Display Only 
 A check box that allows you to specify whether or not the field is display only on this custom 

screen. Select the check box to make the field display only. Clear the check box to make the 

field editable. If the Required check box is selected, you cannot select this check box. 

Derived fields are for display only. 

Required  
A check box that allows you to specify whether or not an entry in this field is required on this 

custom screen. Select the check box to make the field required. Clear the check box to make 

the field not required. If the Display Only check box is selected, you cannot select this check 

box. 

Caption Left  
Allows you to adjust the location of the field’s caption horizontally. The reference point for 

this value is the left side of the caption. 

Caption Top  
Allows you to adjust the position of the field’s caption vertically. The reference point for this 

value is the top side of the caption. 

Caption Width  
Allows you to adjust the width of the field’s caption. The caption will expand to the right 

when edited. 

Caption Alignment  
The alignment of the field’s caption. This field is supported by the Select Alignment popup. 

Using Preview Mode 

The Preview feature is the most powerful feature used with custom screens. It allows you to 

easily design the layout of your screen. Preview mode is accessed from the main Custom 

Screens screen by clicking the Preview button. When you first enter preview mode for a 

custom screen, the locations of the objects are automatically calculated. You can then move 

and size the objects.  

When you enter preview mode for a custom screen, the Custom Screen Editor screen is 

displayed and has a list of objects in the Object dropdown and the custom screen on the right. 

A sample Custom Screen Editor screen is shown below. 
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There are several ways to edit the layout of your screen using preview mode. The details of 

every object on your screen can be edited. This section covers how to select and edit objects 

in preview mode. Tab order is also discussed here. 

Selecting Objects 

You can select a single object by doing one of the following: 

 Click the object name in the Object dropdown. 

 Click the object itself on the screen on the right. 

 

You can select multiple objects by doing one of the following on the screen on the right: 

 Hold down the CTRL key while selecting the individual objects. 

 Using the mouse, right-click on a field object. This will select both the Field and its 

Caption 

 Select a point to the upper left of the first desired object.  Hold down the shift key while 

pressing the left button on the mouse.  While doing so, drag the provided frame from the 

upper left starting position until all desired objects are within the frame (i.e. lassoed).  

Then release the key and mouse.  This will select all the “lassoed” objects, just as if they 

were selected individually. 

 

Editing Objects 

After objects have been selected, there are several different ways to edit them. They are: 

 Move or size the object(s) using the mouse. 

 Move or size the object(s) using key combinations. 

 Move or size the objects using the alignment tools on the Format menu and Tool Bar. 

(This is only available when multiple objects have been selected.) 
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 Edit object properties using the F1 key. 

(If multiple objects have been selected, the first object selected is edited.) 

 

Each of these methods is described below. 

Mouse 

The most common way to edit objects is to simply click-and-drag an object to the position or 

size you’d like. When you first click on an object to select it, you will see the object 

highlighted in red with red squares in each of the corners and on the sides.  

If you move the cursor to anywhere inside the object, the cursor will turn to two crossed lines 

with arrows pointing in four directions. An example of this is shown below: 

 

 

When the cursor looks like the above example, you can drag and drop the object to any 

location you desire.  

If you move the cursor to one of the red squares around the outside of the object, the cursor 

will turn to a line with arrows on either end. This line will either be vertical, horizontal or 

diagonal depending on which red square you are hovering over. It is indicating what direction 

the object will be sized. For example, the following example shows that the object will be 

sized vertically. 

 

When the cursor looks like the above example (or one of the other two direction lines), you 

can drag the object to be the size you desire and then release. 

Note: The cursor will vary based on the operating system being used. For example, the 

cursors shown above are in black, whereas these cursors are white outlined in black in the 

Vista operating system. 

Key Combinations 

After an object has been selected, SHIFT + ARROW keys will change the size of the object, 

while CTRL + ARROW keys will move the object. These hot keys are much more precise. It 

is best to move the object to the general area and size using the click-and-drag procedure, and 

then specify the location and size using the hot keys.  

Alignment Tools 

There are several alignment tools available in preview mode. These tools are found both on 

the Format menu and on the Tool Bar. These tools are only available after you have two or 

more objects selected. The first object selected is the controlling object. The subsequent 

objects selected will be aligned to the controlling object. A description of each tool is given 

below.  

 Align to Left  

 Align to Right  

 Align Spacing  

 Align Height  

 Align Width  

 Align to Top  

 Align to Bottom  
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Align to Left aligns objects to the left side of the controlling object. Align to Right aligns 

objects to the right side of the controlling object. Align Spacing sets spacing between the 

objects to be the same as the spacing between the controlling object and the second object 

selected. Align Height sets height of the objects to be the same as the controlling object. 

Align Width sets width of the objects to be the same as the controlling object. Align to Top 

aligns objects to the top of the controlling object. Align to Botton aligns objects to the bottom 

of the controlling object. 

Screen Sizing Tools 

There are four screen sizing tools available in preview mode. These tools are found both on 

the Format menu and on the Tool Bar. A description of each tool is given below along with 

the key combinations that perform the same task. As you change the screen height and width, 

those settings are updated on the right side of the Tool Bar. If the Screen Type for the custom 

screen does not allow sizing of the screen in width or height, that sizing tool will not be 

available. 

 Decrease Screen Width 

 Increase Screen Width 

 Increase Screen Height   

 Decrease Screen Height 

 

Decrease Screen Width decreases the screen width. ALT + Left Arrow performs the same 

task.Increase Screen Width increases the screen width. ALT + Right Arrow performs the 

same task.Increase Screen Height  increases the screen height. ALT + Down Arrow performs 

the same task. Decrease Screen Height decreases the screen height. ALT + Up Arrow 

performs the same task. 

Tab Order 

When you hover over a field in preview mode, the name of the field is displayed in a tooltip. 

In the tooltip, there is also a number listed after the field. This is the tab order. The tab order 

is determined by the order in which the fields are currently displayed in the grid. This may or 

may not be the order in which you wish to have the cursor move through the fields during 

data entry when using the TAB or ENTER key. To adjust tab order on the screen, exit 

preview mode and then use the Row Down/Row Up buttons to get the fields in the order in 

which you want them to be entered.  

Saving and Restoring 

When you are doing a lot of work in preview mode, we recommend that you save your work 

periodically using the Save option on the File menu. Then, if you make changes that you 

really didn’t want, you can use the Restore option on the File menu to restore the screen to 

the last save. 

A screen can be appended or inserted in the current custom screen  

Note: If you just want to copy an existing custom screen, use the Copy Custom Screen option 

on the File menu. The Copy Custom Screen only allows you to copy custom screens, not 

standard screens. The Append Screen and Insert Screen features allow you to create complex 

custom screens from any existing screens, including standard screens and custom screens. 
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Appending and Inserting Screens 

People-Trak allows you to take an already existing screen (standard, or custom ) and append 

it to or insert it in your current custom screen. This feature is best used when you want to 

make a new custom screen similar to a screen that already exists. You can copy the 

specifications of the pre-existing screen into your new screen and then make the changes you 

desire. This way, you don’t have to start from scratch every time you need to make a new 

custom screen. 

Note: If you just want to copy an existing custom screen, use the Copy Custom Screen option 

on the File menu. The Copy Custom Screen only allows you to copy custom screens, not 

standard screens. The Append Screen and Insert Screen features allow you to create complex 

custom screens from any existing screens, including standard screens and custom screens. 

Recalculating Object Positions 

There might be times when you have moved objects around on a custom screen, saved those 

changes and then decided you want to start over. The Recalculate Object Positions option on 

the File menu allows you to do this. This option recalculates the left and top positions of all 

objects on the custom screen so they will be vertically aligned down the left side of the 

screen. The field and frame objects will also have their width and height recalculated.  

 

Note: There are times when you may not want to use this feature. If you have a two-column 

screen and want to keep it that way, you do not want to recalculate the object positions 

because that would create one single column of objects aligned down the left side of the 

screen. 

Use in Workflows 

A custom screen is displayed within a workflow. First, the custom screen must be added to 

the workflow. Then, it can be accessed when that workflow is open. 

All of the information in the fields placed on the custom screen is displayed. If the custom 

screen is long, scroll bars are automatically activated. You would then enter or update data as 

you would on any other screen.  
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Lesson 1 

Custom Screens 1: Basics 
 
 

Contents 

Tutorial 1.1 – Add, Delete and Copy 12 
Tutorial 1.2 – Create a Simple Custom Screen 14 
Tutorial 1.3 – Using a Custom Screen in a Workflow 16 

 

 
This lesson covers how to add, delete and copy custom screens. It then shows how to create a 

simple custom screen and include it in a workflow.  

Tutorials 
Add, Delete and Copy: shows how to add, delete and copy custom screens. 

Create a Simple Custom Screen: shows how to create a simple custom screen with frames 

and fields. 

Using a Custom Screen in a Workflow: shows how to use the custom screen you created in 

a workflow. 
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Tutorial 1.1 – Add, Delete and Copy 

This tutorial demonstrates how to add, delete and copy a custom screen. These functions are 

available with some of the other tools as well.  

1. Start People-Trak by double-clicking on the People-Trak Trainee icon on your desktop 

(or as instructed).  

 

The Select Product Option screen is displayed.  

2. The Position Control and Attendance options should be the only options that are 

toggled on. If they are not, select the Training button. 

3.  Select the Strategic Toolkit option. 

4. Click OK. 

 

The Login screen is displayed. 

5. In the User ID field, enter DEMO. 

6. In the Password field, enter DEMO. 

 

The Organizer desktop is displayed with the Personnel Management module selected. 

Let’s start by creating a custom screen. 

7. On the Tools menu, select Custom Screens.  

 

The Custom Screens screen is displayed. The Custom Screens screen provides a list of 

the current custom screens on the left and a data entry area on the right. A Menu Bar and 

a Tool Bar are provided to enable you to fully manage your list of custom screens. Let’s 

get started and create a custom screen. 

8. On the File menu, select New Custom Screen or on the Tool Bar, click the New Custom 

Screen button to start a new custom screen.  

 

A default name will be assigned. The name is NEW-#, where “#” is the next available, 

unused number. 

9. Change the name of the screen to My Custom Screen, but do not change anything else 

yet. 

 

The reason you did not waste any time completing the custom screen is that you are 

going to learn how to delete custom screens, and the screen you just created is the one 

that must go. 

10. Make certain that your custom screen is the currently selected screen. On the File menu, 

Delete Custom Screen or on the Tool Bar, click the Delete Custom Screen button to 

delete your custom screen.  

 

The following message is displayed: 

Delete the current Custom Screen? 
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11. Click Yes and say goodbye to your custom screen. 

 

Now let’s create another new custom screen and try the copy feature, which is very 

helpful when you want to create a screen that is very similar to another screen. 

12. Create a new custom screen. Change the screen name to My Custom Screen, but do not 

bother to change anything else. Click the Save button to save your changes. 

13. On the File menu, select Copy Custom Screen. 

 

A new screen is created named My Custom Screen-1 and all of the settings in My 

Custom Screen (not much in our case) are copied to this new screen. At this point you 

would typically rename this new screen and change any settings that you desire. We 

won’t bother to do all of that as that is pretty straightforward. 

14. Delete the My Custom Screen and My Custom Screen-1 screens. 

15. Close the Custom Screen screen. 

16. Continue with the next tutorial. 
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Tutorial 1.2 – Create a Simple Custom Screen 

A custom screen is a list of objects that determine what is on the screen and what it looks 

like. There are many different objects available. We will start by learning how to use frames 

and fields to create a simple custom screen. 

17. On the Tools menu, select Custom Screens and create a new custom screen using what 

you learned in the prior lesson. Name the custom screen My Name and Address. 

 

As with documents, the Category field is used for security. With screens, the Category 

field also determines the category in which notes are stored for this screen. The Category 

is defaulted to User but can be changed to any of the pre-defined categories. 

18. In the Category field, select Personal. 

 

The Screen Type field allows you to select the type of custom screen that you are 

creating. The screen type chosen controls what screen sizing is available.  

19. In the Screen Type field, click the popup button. 

 

The Standard screen type uses the standard People-Trak size screen and allows you to 

have variable height with scroll bars. The Popup screen type gives you the ability to size 

the screen to any size you desire. The Maximum screen type allows you to use the 

maximum space allowed in People-Trak screens.  

20. Select Standard.   

 

The Screen Width and Height fields show the default screen size in pixels for this screen 

type. The Screen Width is display only but the Screen Height is not, which allows you to 

create a much longer screen, if necessary.    

21. In the Object Type column on the first blank row in the grid, select the popup button to 

display a list of the valid object types. Select a Frame for the first object. 

 

For each object type, some of the remaining columns are used to provide details. For a 

Frame object, the only relevant column is typically the Caption. We will get fancier with 

a Frame object in a later tutorial and use the Object Name column at that time, but not 

now. 

22. In the Caption column, enter Name. 

 

Now let’s pick some fields that will be placed within the frame. 

23. In the Object Type column on the second row in the grid, select a Field object.  

24. In the Object Name column, click the popup button to display a list of the fields in the 

Personnel Management module. Select the First Name field.  

 

The Caption column is automatically set to the caption currently associated with this 

field. (In the case of the First Name field, the caption is set to First Name.) This can be 

changed, if desired, but we have no need to make a change at this time, so just leave the 

field as is. 

Similar to what we saw in form templates, the Left and Top fields are set to  -1 to let the 

system know that these coordinates need to be calculated. This calculation will happen 
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when first going into preview mode or when saving. The Width and Height fields contain 

the width and height of the field in pixels. We’ll learn more about these attributes later. 

Let’s pick some more fields. 

25. Add the Middle Name and the Last Name fields to your custom screen. When complete, 

you should have a frame and three fields.  

 

Now let’s add another Frame.  

26. Select the Frame object and then set the Caption to Address. 

27. Add the following Fields:  

 

Address 1 

Address 2 

City 

State 

Zip Code 
 

You should now have two frames and two collections of fields. We will just take a quick 

look at Preview to see how this looks. We will actually move and size the fields in 

another lesson. 

28. Click Preview. 

 

The Custom Screen Editor screen is displayed. Everything looks good. 

29. Close preview mode. 

 

Note that the -1 values have now been calculated to be the correct pixel coordinates. 

 

In the next tutorial, we will see how this custom screen looks “live and in action”. 

30. Close the Custom Screens screen, saving your changes. 

31. Continue with the next tutorial. 
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Tutorial 1.3 – Using a Custom Screen in a Workflow 

Custom screens, like all other screens, are displayed within a collection of one or more 

screens known as a workflow. We just created a new custom screen. Now we have to put it 

on a workflow so that we can see it and use it. You will learn more about workflows in a later 

lesson. For this tutorial, we will just walk you through what you need to do to get your 

custom screen onto a workflow. 

1. On the Tools menu, select Workflows. On the Tool Bar, click the New Workflow button 

to create a new workflow. Change the Workflow Name to My Name and Address 

Workflow. Leave the Show on Menu check box selected so that this workflow will 

show up on the Workflows menu.  

 

We need to add your new screen to the workflow.  

2. On the Screens tab, in the Screen Name field, click the popup button to display a list of 

the available screens. Select the My Name and Address screen. Close the Workflows 

screen, saving your changes. We now have a workflow with your screen. 

3. Open the Workflows menu. Your new workflow should be present. Select the workflow 

and open Donald Stern’s record. 

 

Note that all of his name and address information is displayed in your new screen.  

4. Close the record. 

 

That is a simple, single-screen workflow using your customized screen. 

 

Now, most people would like to use their custom screens along with other screens within 

People-Trak. Let’s learn how to add a screen to an existing workflow. 

5. On the Tools menu, select Workflows. Select the Standard - Employee workflow.  

 

This is the standard workflow for the Personnel Management module.  

6. Click the Screens tab.  

7. Click on the Status screen row. On the Tool Bar, click the Insert Row button and insert 

your newly-created My Name and Address screen as the second screen in the Standard 

- Employee workflow. 

8. Close the Workflows screen, saving your changes. 

9. Use the Open Employee shortcut to open Donald Stern’s record within the Standard - 

Employee workflow. 

 

When the record is displayed, the second screen will be your customized screen and the 

rest of the screens will be the standard screens that come with People-Trak.  

10. Click through the screens to check this out. 

11. Close Donald’s record.  

12. This concludes this tutorial and lesson. 
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This lesson covers how to use preview mode to make adjustments to your custom screen. It 

also covers how to change the tab order of the fields on your custom screen. 

Tutorials 
Using Preview Mode: demonstrates how to move and size some of the objects you have 

placed on the custom screen. 

Object Properties: demonstrates how to make changes to the location and size of objects on 

a screen by using the Object Properties screen. 

Alignment Tools: takes you on a tour of the alignment tools available in preview mode. 

Tab Order: demonstrates how to change the order in which you wish to have the cursor 

move through the fields during data entry. 
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Tutorial 2.1 – Using Preview Mode 

We have used preview mode before, but now we are going to actually move and size some of 

the objects you have placed on the custom screen. 

1. On the Tools menu, select Custom Screens. Select your My Name and Address custom 

screen. 

2. Click the Preview button to activate preview mode.  

 

In preview mode, you should see your screen based on the calculations and assumptions 

made by the Custom Screens process. With a simple screen such as this, everything 

should look pretty good. 

 

The first time that you use preview mode with a new screen, the various calculations and 

assumptions are made. For example, in your screen, the fields were placed in the frames 

correctly and the spacing was consistent. If we make another change, such as adding an 

additional field, the calculations will not be redone and we will need to use the features in 

preview mode to adjust the screen. Since that is what we are here to learn, let’s add 

another field to the screen. 

3. Close preview mode. 

4. In the first blank row in the grid (after the Zip Code field), add the Country field. Now, 

click the Preview button and take a look at the screen. 

 

The Country field now overlaps the bottom of the Address frame because the Address 

frame height was not recalculated. Well, preview mode can be used to fix the problem, 

and we’ll do that now. 

5. Activate the Address frame object by either selecting Frame - Address in the Object 

dropdown on the Tool Bar or clicking on the outside edge of the Address frame on the 

screen on the right. Now move the cursor to the bottom of the frame until the up/down 

arrow cursor appears. Click and hold the mouse button down and slowly drag the bottom 

of the frame downward until the Country field is within the frame. Click off the frame to 

deactivate movement. 

 

The screen looks OK now, but how would you like People-Trak to ‘fix’ screens for you 

after you have added one or more fields after the initial preview? It can!  

6. Close preview mode, saving your change. 

7. Add the County field below the Country field in the grid. 

8. Click the Preview button.  

 

Just like with the Country field, the County field is added below the frame it should be 

included within.  

9. Leaving the County field outside of the frame, close preview mode. 

10. On the File menu, select Recalculate Object Positions. 

 

This option recalculates the left and top positions of all objects on the custom screen so 
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they will be vertically aligned down the left side of the screen. The field and frame 

objects also have their width and height recalculated.  

11. Enter preview mode. 

 

The County field is now included in the frame automatically. This recalc option can also 

be used to save yourself some grief when you have made a lot of changes to a screen and 

just want a ‘do over’.  

 

Note: There are times when you may not want to use the Recalc Object Positions feature. 

If you have a two-column screen and want to keep it that way, you do not want to 

recalculate the object positions because that would create one single column of objects 

aligned down the left side of the screen. 

 

When creating form templates, we learned how to drag, drop, and nudge objects. We will 

be refreshing your memory by moving a few objects around in this custom screen.  

Let’s start by moving the Zip code field. 

12. Click on the Zip field using the right mouse button. 

 

Both the Zip field and its caption are highlighted. 

13. Click and drag the Zip field and its caption up so that it is aligned horizontally with the 

State field. You can align the right edge of the Zip field with the right edge of the City 

field. 

 

Now that the Zip field has been moved, the Country and County fields are too low and 

the frame is too low. As we have seen previously, moving multiple fields can be done 

with a few clicks. 

14. Right click on the Country field to select the field and caption. Hold down the CTRL 

key and right click on the County field to select the field and caption as well. 

15. Move the Country and County fields and their captions up under the State field. 

16. Select the Address frame that should be too long now that we have moved the fields up. 

Hold down the SHIFT key and press the UP ARROW key. This will move the bottom 

of the frame up one pixel at a time. You can use the DOWN ARROW key to extend the 

frame downward one pixel at a time. Finally, you can use the RIGHT ARROW key and 

the LEFT ARROW key to expand or contract an object horizontally. Try them now as 

you clean up your screen and prepare it for use. 

 

The actual size of the screen itself can also be changed if the screen type chosen allows it. 

In our case, we are using a Standard screen, so we can change the height to whatever we 

desire. If we make the screen shorter, it won’t make any difference if the screen is used as 

a primary screen because a primary screen has a fixed minimum size. If we make the 

screen longer, a scroll bar will be available.  

 

Let’s assume that our screen is going to be used as a primary screen as well as a sub 

screen. With sub screens, making the screen smaller does affect the actual screen size. 

Let’s make the screen smaller now. The technique is similar to the sizing you just did of 

the frame, except the ALT key is used instead. 
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17. Hold down the ALT key and press the UP ARROW key a couple times to move the 

bottom of the screen up a bit, decreasing the screen height.  

 

Note: Screens with a type of Popup also allow you to change the width of the screen. The 

ALT + LEFT ARROW and ALT + RIGHT ARROW key combinations move the right 

side of the screen left and right, respectively. 

 

These functions are also available as buttons on the Tool Bar.  

18. Find the two blue buttons for Increase / Decrease Screen Height on the Tool Bar and 

give each one a try. Then use the appropriate buttons to size the screen to the size of the 

data area.  

 

Tip: When you are doing a lot of work in preview mode, we recommend that you save 

your work periodically using the Save option on the File menu. Then, if you make 

changes that you really didn’t want, you can use the Restore option on the File menu to 

restore the screen to the last save. 

19. Stay in preview mode for the next tutorial. 

20. Continue with the next tutorial. 
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Tutorial 2.2 – Object Properties 

All of the moves and sizing tasks that you just performed were recorded in the object’s 

property settings. Let’s take a look at how to see these properties for each object on the 

custom screen.  

1. Either select Field - County in the Object dropdown or click on the County field on the 

screen on the right to activate it. 

2. Press the F1 key. 

 

The Field Object Properties screen for the County field is displayed. 

 

Note that the Object Type and Field Name fields are display only. You can only change 

those settings from the object grid on the main screen. 

 

The Left, Top, Width and Height fields are in pixels and are updated when objects are 

moved or sized in preview mode, or you can update these fields here in this screen. These 

fields can also be updated on the main Custom Screens screen. The Left and Top 

numbers are relative to a 0/0 starting point, which is in the upper left corner of the screen. 

3. Record the value of the Left field and close the Field Object Properties screen. 

4. Now drag the County field to the right.  

5. Press the F1 key to display the Object Properties screen again. 

 

Note that the value of the Left field has been updated to reflect the movement of the 

object. 

 

To restore your screen, simply update the coordinate back to the value you recorded.  

6. In the Left field, enter the number you recorded. Click the Apply button to apply the 

change. 

 

You can see that the change took effect.  

 

The calculations and assumptions that the Custom Screens process makes also prevents 

an object from being placed outside the viewable area of the screen.  

 

We can simulate this problem now.  

7. Press F1 again and change the Top field for the County field to 1000.  Click the Apply 

button to apply the change. 

 

The County field is moved down to the bottom edge of the screen. If you decreased your 

screen height significantly in the last tutorial, it may even be “missing” altogether. We 

can look at the object grid and see how the details for this field have been modified.  

8. Close preview mode, saving your changes. 

9. Look at the entries in the Top column for the objects.  

 

When you get to the County field, the Top entry really makes a big jump to something 

around 500. The 1000 you entered was adjusted to what the normal screen maximum is. 
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10. Change the Top column for the County field to 250, which is much closer to the Top 

entry for the Country field. Open preview mode. 

 

The County field should be almost exactly where it needs to be. 

11. Nudge the County field back to where it belongs. 

12. Stay in preview mode for the next tutorial. 

13. Continue with the next tutorial.  
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Tutorial 2.3 – Alignment Tools 

You have already seen several different ways to move objects on your custom screen. Let’s 

take a look at some really slick alignment tools that will save you a lot of time and effort. 

1. Right click on the County field on the screen on the right. 

 

As expected, the County field and its caption are automatically highlighted. 

2. Click and drag that field and its caption down toward the bottom of the screen and keep it 

highlighted. 

3. Make the County field a lot bigger by moving the mouse down to the lower right-hand 

corner of that field until the cursor becomes a diagonal with arrows on both ends. Now 

drag down and to the right. 

4. Click in the empty area off to the right of the County field to deselect it. 

 

Now, let’s not only get this field and its caption back to “about” where they belong, let’s 

get them back to exactly where they belong and back to the right size! 

 

First, let’s get the County caption back where it belongs. 

5. Click on the State caption. Now, hold down the CTRL key and click on the Country 

caption and then the County caption. 

 

Notice the difference in the way these fields are now highlighted. The State caption looks 

different from the other captions because it is the “controlling” object. Every other 

highlighted object will align to that.  

 

We are now ready to use the alignment tools, which are available on the Tool Bar (and 

also on the Format menu). The graphic for each button is pretty self-explanatory. 

6. Take a moment and move your mouse over each button on the Tool Bar. As you right 

click on each button, a tooltip description will display. 

 

Now that you are familiar with the alignment buttons, let’s start clicking! 

7. On the Tool Bar, click the second button, which aligns objects to the right. 

 

The County caption is now right aligned to where the State caption is. The three objects 

should still be highlighted. 

8. On the Tool Bar, click the third button, which sets spacing between objects.  

 

Voilà! The County caption is back where it belongs! 

 

Now do similar steps for the County field. 

9. Click on the State field. Now, hold down the CTRL key and click on the Country field 

and then the County field.  

 

This time, we want those fields left aligned and then spaced correctly. 
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10. On the Tool Bar, click the first button, which is the left align button. Then click the 

spacing button.  

 

The County field is now back where it belongs. But it is still way too big. Let’s fix that. 

11. On the Tool Bar, click the fourth button, which sets the height of the selected objects. 

 

The County field should now be the same height as the State field. 

 

There is only one thing left to do, make the County field the right width. If we did this 

right now with the State field selected, the Country and County fields would also get set 

to the State field length, which is not what we want.  

12. Click on an empty area of the screen to deselect the objects. 

13. Click on the Country field. Hold down the CTRL key and click on the County field. 

14. On the Tool Bar, click the fifth button, which sets the width of the selected objects. 

 

The County field should now be the same width as the Country field. 

 

The only alignment tool we haven’t tried yet is the one that aligns fields at the top. I think 

you can tell from the graphic which one that is. We won’t try that one but you know how 

to use it now. 

15. Click on an empty area of the screen to deselect the objects. 

16. Save your changes and stay in preview mode for the next tutorial. 

17. Continue with the next tutorial. 
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Tutorial 2.4 – Tab Order 

Tab order is the order in which the cursor moves through fields when the TAB or ENTER 

key is used. Tab order is determined by the order in which the fields were selected or are 

currently displayed in the grid. This may or may not be the order in which you wish to have 

the cursor move through the fields during data entry.  

It is important to be able to see the tab order while in preview mode, and you can.  

1. Hover over any Field object on the screen on the right.  

 

A tooltip is displayed with the field name followed by a colon and a number. As you 

learned earlier, the number is the tab order for the field. When you use the TAB key or 

ENTER key to move through the fields on the screen, the cursor will follow the tab order. 

The first field is tab order 1, the second field tab order 2, etc. 

 

The tab order is determined by the order in which the fields are currently displayed in the 

grid. This may or may not be the order in which you wish to have the cursor move 

through the fields during data entry. When you created the screen and initially selected 

the fields, you selected Middle Name as the second field. 

2. Hover over the Middle Name field, you can see that it is tab order 2. The Last Name 

field was the third field and if you hover over that field, you can see that the tab order is 

3. 

 

Now, after having created our screen, we may have decided that the tab order is wrong. 

Perhaps we would prefer the cursor to tab to fields as they appear on our screen. We can 

fix this quite easily. Again, tab order is determined by the order in which the fields are 

currently displayed in the grid.  

3. Close preview mode.  

4. Click anywhere on the Middle Name row in the grid. On the Tool Bar, click the Row 

Down button to push the Middle Name field in the grid down one row so it is now the 

third field listed in the grid. When complete, go back into preview mode. Now hover over 

the Middle Name field and the tab order should be 3.  

 

You can adjust tab order on any custom screen that easily. 

 

In this particular example, we have created a strange situation. The tab order does not 

match the field order on the screen. Let’s take a look.  

5. Close preview mode and Custom Screens screen, saving your changes. 

6. Use the Open Employee shortcut to open Donald Stern’s record within the Standard - 

Employee workflow and display your custom screen. Press the TAB key a few times. 

 

Note that the cursor moves in a different order than the order in which the fields are 

actually displayed. At some point you may wish to have tab order and field order be 

different. However, the most common use of adjusting tab order is when you have 

initially selected fields that do not end up being placed in the order in which you selected 

them. (I had you select the fields in the proper order, but I will not always be around to 

help you.) 
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Tab order, like field location, can be changed on any custom screen whenever you wish 

to do so.  

7. Close the open record.  

8. Continue with the next tutorial. 
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This lesson covers how to use the Display Only and Required attributes of a field to control 

data input on a custom screen. The lesson concludes by showing you how to add screen help 

to a custom screen. 

Tutorials 
Display Only and Required: demonstrates how to use the Display Only and Required 

attributes of fields on your custom screen to control data input. 

Adding Screen Help: shows how to add screen help to a custom screen. 
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Tutorial 3.1 – Display Only and Required 

Let’s see how the Display Only and Required attributes of fields on your custom screen allow 

you to control data input.  

1. Open a record to verify that the name and address information are displayed on both the 

Personal screen (the first screen) and your My Name and Address screen (the second 

screen). Close the record. 

2. On the Tools menu, select Custom Screens and then select the My Name and Address 

screen. 

3. Open preview mode.  

4. Click on the First Name field on the right. Press F1 to display the Field Properties 

screen and select the Display Only check box. Click Apply to apply those changes. Do 

this same procedure for the Middle Name and Last Name fields. 

 

Now, let’s specify that we want all of the address fields to be required. We could use the 

F1 key, but there is a faster way to make these changes. 

5. Close preview mode. 

6. For each of the address fields, select the Required check box in the Objects grid. 

 

As you can see, you can change the Display Only and Required attributes of fields on 

your custom screen using either the Objects grid on the main screen or the F1 key when 

in preview mode. 

7. Close the Custom Screens screen, saving your changes. 

8. Open Donald Stern’s record.  

 

Note that the name and address fields on the Personal screen (the first screen) do not 

share the attributes we just set for the same fields that appear on your screen.  

9. Go to the second screen.  

 

On this screen, the name fields are now for display only and the address fields are 

required.  

 

You can tell that the name fields are for display only because the data is displayed in 

gray. In addition, the cursor jumps over these fields when you use the TAB or ENTER 

key. (The cursor will position to a display-only field if you use the mouse, but will not 

allow editing.) 

 

You can tell that the address fields are required because you cannot clear the value of a 

required field.  Try it. 

10. Attempt to clear the Address 1 field and then leave. You will not be able to do so.  

 

And, of course, if you attempt to leave the screen with any required field blank (even one 

you did not position to), your attempt will fail. 

 

This tutorial demonstrates the ability to set display only and required attributes by screen. 



Database Manager 

 

 Introduction to Custom Screens     29 
 

In this example, we used the same fields on two different screens in the same workflow. 

On one screen, the attributes were set and on another they were not. You could just as 

easily create a single screen workflow that provides display-only information for a 

particular user or group of users. 

11. Close the record. 

 

Let’s do some housekeeping. 

12. On the Tools menu, select Custom Screens and then select the My Name and Address 

screen. 

13. Remove all of the Display Only and Required selections in the Objects grid.  

14. Save your changes and stay in the Custom Screens screen. 

15. Continue with the next tutorial. 
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Tutorial 3.2 – Adding Screen Help 

Each of the screens within People-Trak is provided with screen help. This help provides a 

basic description of the screen and what it is used for. This help can be activated in one of 

two ways. You can press SHIFT +  F1 (the F1 key alone displays field help for the current 

field). Or you can use the Show Screen Help button on the Toolbar. 

You should still be in the My Name and Address screen. 

1. Click the Help button to display the help text for the screen.  

Because we created this screen from scratch, the help text is blank.   

2. Select the Edit button. 

The Help Editor is displayed. 

3. Enter the following text: 

This screen is used to enter personal information regarding the employee’s name 

and address  
 

Remember, from this point forward, this is the text your users will see when they seek 

help for this screen. Your users are counting on you.  

4. Close the Help Editor, the Topic Name: My Name and Address screen and Custom 

Screens screen, saving your changes. 

 

Time to test your screen help. 

5. Open Donald Stern’s record. Select your My Name and Address screen. Press SHIFT 

+ F1 to display the screen help. You should see the help you just created. Close the 

screen and try displaying your help using the Show Screen Help button on the Toolbar. 

Close the screen. 

 

That’s it. You can add or change screen help whenever you need to. 

6. Close Donald’s record.  

7. Continue with the next tutorial. 
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This lesson covers some more objects available in custom screens. 

Tutorials 
Displaying Other Screens: shows you how to use the screen object to display other screens. 

Using Labels: demonstrates how to use the label object on your custom screen. 

Buttons: A Sneak Preview: shows how to use buttons on your screen to trigger actions. 

Captions, Lines, Pictures and Hyperlinks: demonstrates how to use these objects to give 

your custom screen some pizzazz. 
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Tutorial 4.1 – Displaying Other Screens 

A very powerful capability of custom screens is the ability to display any other screen that is 

within the module. This is accomplished with the Screen object. Screen objects are essentially 

buttons that are associated with the name of a screen. When you create a screen object, you 

select the screen you want to display. This puts a button on your screen. You can then 

position the button wherever you wish. When your custom screen is displayed, you can click 

on the button to display the specified screen. Let’s give it a try. 

1. On the Tools menu, select Custom Screens and then select the My Name and Address 

screen. 

2. Position to the first blank row in the objects grid. In the Object Type field, click the 

popup button to display a list of the available objects. Select the Screen object. In the 

Object Name column, click the popup button to display a list of the available screens. 

Select the Personal screen.  

 

The screen code is placed in the Object Name column and the name of the screen is 

placed in the Caption column.  

3. Enter preview mode.  

 

You should see a button with the caption Personal. This is the screen object we have just 

created. The screen object can be sized and positioned just like the other objects you have 

learned about so far. Try it now.  

4. Make the Personal button taller and wider. Close preview mode, saving your change. 

5. For the Screen object, change the Caption to Personal Screen. Enter preview mode and 

make certain that the button is large enough for the caption. Close preview mode.  

 

Let’s take a look at this screen now. 

6. Close the My Name and Address screen, saving your changes. 

7. Open Donald Stern’s record. Select your custom screen.  

 

This screen contains personal information about the employee and a button to display the 

Personal screen provided with People-Trak. Now for some interesting results. 

8. Change Donald Stern’s Last Name to Sternz. Now click on the button to display the 

Personal screen.  

 

This screen displays the employee’s Last Name. Note that the Last Name field shows the 

latest change to Donald’s last name. It appears as Sternz. Because the Personal screen is a 

sub screen on your custom screen, it displays the latest available information. 

9. Close Donald’s record, saving your changes. 

10. Return to the Custom Screens process and select the My Name and Address screen we 

have been working on.  

 

It’s time to add another screen. 
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11. In the next blank row, add another Screen object. This time, select the screen we are 

currently working on. Yes, we are going to display this screen as a sub screen on itself. 

Use preview mode to make certain everything looks right and to make any necessary 

adjustments. If you don’t see this new screen object as a button in the screen on the right, 

just select it in the Object dropdown to find it and then drag that button down so it is 

visible. Close preview mode, saving your changes. Close the Custom Screens screen, 

saving your changes. 

12. Open Donald Sternz’s record. Select your custom screen. Click on the screen button to 

display this very same screen as a sub screen. Other than the size of the screen (sub 

screens do not fill the workflow area), the screen is the same. Close the screen. 

13. Change Donald’s last name back to Stern. Open the sub screen again and note that the 

change is there as well.  

 

Now for something really interesting. On the sub screen, there is… another button for the 

same screen.  

14. Click on the screen button.  

 

We are now displaying a sub screen on a sub screen on a main screen, all of which are the 

same screen.  

15. Reposition the topmost screen to view the original sub screen.  

 

But wait… the sub screen is there again. You could click the button and then click it and 

then click it again, but eventually People-Trak will become angry and shut down. In 

actuality, there really is no reason to nest the screen on top of itself once, let alone three 

or four times. If the information is displayed and can be edited once, that is sufficient. 

16. Close all of the nested screens, and then close Donald Stern’s record, saving your 

changes.  

17. Continue with the next tutorial. 
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Tutorial 4.2 – Using Labels 

There are two types of label objects. There are label objects that are actually part of the field 

objects. These are known as caption labels. Then there are dedicated, stand-alone labels that 

are used to present information to the user. You learned about them just briefly in previous 

training. We’ll work with them a bit more now. 

Working with People-Trak, you have probably seen that most screens are fairly dense and 

that we try to capture as much information on a given screen as possible. This technique is in 

contrast to the “wizard” method where you can present lots of text and then collect just one or 

more pieces of information. With People-Trak, you can have it your way. You can create 

screens with fewer fields and more text. The way to do that is to use label objects. 

1. Start a new custom screen. Name the screen Wizard Screen and put it in the Personal 

category. In the Screen Type field, select Popup because we are going to use this screen 

as a popup screen and would like to size it accordingly.  

 

Note: This doesn’t mean that this screen can only be used as a popup screen. If the screen 

is used as a primary screen, it will be sized according to the minimum screen size for 

primary screens. 

 

Now let’s get started. 

 

Labels usually look best displayed within a frame.  

2. So, begin by adding a Frame object. Do not add a Caption for the frame. Now, before 

adding the Label object, enter preview mode and size the frame so that it is about half the 

size of the available space. Size the screen itself (using the ALT key plus arrow key 

combination or the screen sizing buttons on the Tool Bar) so that the borders around the 

frame are about one-quarter of an inch. Then close preview mode, saving your changes. 

3. Add a Label object to the screen.  

 

The Caption column for the Label object is defaulted to Sample Caption. This is done to 

ensure that you can see the label in preview mode. We will leave that placeholder there 

for now and replace it in a bit.   

4. Enter preview mode and size the label object so that it is just inside the left, top, and right 

borders of the frame. Leave about an inch between the bottom of the label object and the 

bottom of the frame object. Close preview mode, saving your changes. 

5. Now add two Field objects. Select the Termination Date and Termination Reason 

fields. Enter preview mode and move the two fields to the available space below the label 

object. Line them up vertically and center them horizontally. Close preview mode, saving 

your changes. 

 

Now we can finally add the text of the label.  

6. In the Caption column for the Label object, click the two-arrow popup button to display 

the Simple Editor.  

 

This is where you can enter a very large amount of text.  
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7. Enter the following text:  

 

This screen is used to terminate an employee. Please complete each field carefully. 

In the termination date, enter the date when the employee’s termination was 

effective. Remember, in some instances, this is not the last day the employee worked. 

Sometimes employees are terminated officially some number of days after they are 

asked to leave the premises. After the date has been entered, complete the 

termination reason field. The termination reason field is supported by a list of the 

approved and valid termination reasons. Select the appropriate reason. And before 

continuing, please make sure you are terminating the right employee. 

8. Click OK. 

9. Enter preview mode and see how the wizard looks now. You may need to move a few 

objects around or size the label. When complete, close preview mode, saving your 

changes. 

10. Select the My Name and Address screen we have been working on in prior lessons. Add 

a new Screen object at the bottom of the list of objects. Select the Wizard Screen we 

have just created and then set the Caption to Terminate. Use preview mode to adjust the 

size and location of the screen object. Close preview mode, saving your changes. Close 

the Custom Screens screen, saving your changes. 

 

Now let’s see how it works. 

11. Open Donald Stern’s record. Move to your custom screen. Click the Terminate button. 

Your very own termination wizard screen is displayed. You have a meaningful message 

with instructions for completing just two fields. Close the screen without terminating 

Donald Stern. We need him around for future lessons. Close Donald Stern’s record. 

 

You have now created a wizard style screen using a label and just two fields. You can 

actually create screens with any number of fields and in fact, you can create screens that 

do not have any fields at all. These would be known as message screens. We’ll build one 

now. 

12. Select the Custom Screens option and create a new custom screen. Name the screen 

PANIC and put it in the Personal category. In the Screen Type field, select Popup 

because this screen is going to be a popup. 

13. Add a Frame object and a Label object. Add the following text to the Label object:  

 

PANIC. The sky is falling. Please run around and scream nonsensical phrases while 

waving your arms wildly and achieving absolutely nothing meaningful. PANIC. 

14. Enter preview mode. Size the Frame object so that it can contain about two or three lines 

of normal text. Center the Label object within the frame. Size the screen itself to just 

larger than the Frame object. Close preview mode. Save your screen.  

15. Select the My Name and Address screen and add a new Screen object. Select the 

PANIC screen. Set the Caption of the Screen object to PANIC. The only thing left is to 

try it. Close the Custom Screens screen, saving your changes. 

16. Open Donald Stern’s record. Select your custom screen. Now… click the PANIC 

button. There are your explicit instructions. Please comply. 
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In reality, text-only screens can be useful for providing information. In addition to Label 

objects, you can use HTMLabel objects. The HTMLabel object is used for formatted text, 

is edited with the HTML Editor and uses a style sheet for its formatting (specified in 

Desktop Setup); whereas, the Label object is used for non-formatted text, is edited with 

the Simple Editor and uses the standard PT style or the alternate style. You will get to 

play with the HTMLabel object a bit later.  

17. Close Donald’s record. 

18. Continue with the next tutorial. 
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Tutorial 4.3 – Buttons: A Sneak Preview 

Buttons are very powerful objects that can perform a wide variety of tasks. Button objects 

refer to button triggers that are created with the Button Triggers tool. We will be learning a 

great deal about button triggers later, but we will learn just enough at this time so that you 

know how to use a button object in a custom screen. 

1. Select the Custom Screens option and select the PANIC screen we created in the last 

tutorial.  

2. On the first blank row, add a new Button object. Leave the Object Name blank for now. 

Set the Caption to SCREAM. Open preview mode, find the SCREAM button, and then 

position it where it is quite easy to find. Close preview mode, saving your changes.  

 

Now, we would normally use the Object Name column to select the button trigger to 

execute, but we do not have one yet. We’ll need to create one now.  

3. Close the Custom Screens screen, saving your changes.   

4. On the Tools menu, select Button Triggers. On the Tool Bar, click the New Trigger 

button to create a new button trigger. Set the Trigger Name to SCREAM and set the 

Button Caption to SCREAM.  

5. Click the Actions tab. 

 

Button triggers can perform a number of actions. Again, we’ll learn about these later. Just 

follow along as we create a trigger and make notes for future reference. 

6. In the first blank row in the Actions grid, click the popup button to display a list of the 

available action types. Select the Update Field action.  

 

This action is used to force the contents of a field to a specific value. For example, you 

could set the value of the City field to a specific city or the value of the Country field to a 

specific country. 

 

When you selected the Update Field action, the cursor moved to the second row. 

7. Click back in the first row and then click the Detail:1 button. 

 

The Update Field screen is displayed. 

8. In the Field Name field, click the popup button to display a list of the available fields. 

Select Last Name. Set the New Value Type field to Value. Set the New Value field to 

Ahhhhhh. 

9. Close the Update Field and Button Triggers screens, saving your changes. 

10. Select the Custom Screens process and select the PANIC screen. Position to the 

SCREAM button object and use the button on the Object Name column to display a list 

of the available button triggers. Select the button named SCREAM that we just created. 

 

We now have a button object that executes a button trigger when the button is clicked. 

All we need to do now is try it out.  

11. Close the custom screen, saving your changes.  
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12. Open Donald Stern’s record. Select your My Name and Address screen. Click the 

PANIC button to display the PANIC screen you created. The SCREAM button object 

should be visible. Click the SCREAM button.  

 

This will execute the trigger that will change Donald Stern’s Last Name to Ahhhhhh, 

which is essentially a scream. There is no Last Name field on the PANIC screen, but 

there is one on the screen below that.  

13. Close and save the PANIC screen so you can see the Last Name field. Click the Save 

Employee button.  

 

The Last Name should now be Ahhhhhh. We have had a moment of panic and we have 

screamed.  

14. Just to provide a little more information about the Update Field action, move to the 

Personal screen. 

 

Note that Last Name field there also reflects our moment of panic. Setting a field with a 

trigger is the same as typing the value in directly. 

15. Change Donald’s Last Name back to Stern. 

16. Close Donald’s record, saving your changes.  

17. Continue with the next tutorial. 
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Tutorial 4.4 – Captions, Lines, Pictures and Hyperlinks 

People-Trak provides four different caption objects to allow you to have “headings” on your 

custom screens. A line object is also available, which gives you the ability to draw lines.  A 

picture object allows you to add pictures to your custom screens. And last, but not least, there 

is also a hyperlink object, which allows you to add a hyperlink to your screen. So many 

objects, so little time! We will take a look at each of these objects in this tutorial to get 

familiar with them. In a later lesson, you will be putting these all together to make a really 

cool screen. 

1. Start a new custom screen. Name the screen Fun with Objects and put it in the Personal 

category. Leave the Screen Type field set to Standard. 

 

Now let’s get started. Let’s first see what the differences among the headings are. 

2. So, begin by adding a Heading 1 object with a Caption of Heading 1.  

3. Next, add Heading 2, Heading 3 and Heading 4 objects with the same-named Heading. 

4. Enter preview mode. 

 

The Heading 1 and 2 objects have the dark color of your selected scheme as their 

background; whereas, Heading 3 and 4 objects have a transparent background. Also 

notice the difference in the font size of the heading text.  

 

As with all objects, you can resize these headings to be any size you want and you can 

move them anywhere on the screen. 

5. Practice moving and resizing the objects.  

6. Add a Line object. There is no Caption needed for a line object. 

7. Enter preview mode. 

 

The line defaults to a thickness that makes it easiest to resize in any direction you want. 

You can make the line thinner if you want. 

8. Highlight the line object on the right. 

 

Let’s make the line thinner. 

9. Move the cursor over either the top or bottom red box in the middle of the line until it 

changes into an up/down arrow, and then drag the line down or up (depending on which 

red box you selected) to make the line thinner. 

 

Let’s make the line thicker again. We can either do the same method in the other 

direction or use the nudge technique. Let’s do a refresher on the nudge technique. 

10. With the line still highlighted, hold down the SHIFT key while pressing the DOWN 

ARROW key. 

 

The line will now become thicker. 

 

Now, let’s make the line longer. 
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11. Move the cursor over the right side of the line until it changes into a left/right arrow, and 

then drag the line to the right. 

12. Practice resizing and moving the line. 

13. Close preview mode, saving your changes. 

14. Add a Picture object to the screen. 

15. In the Object Name field, click the popup button. 

 

As you can see, you can select one of the button triggers just like you could with the 

Button object. This allows you to have your picture act as a button. We won’t be doing 

that until a bit later. For now, our picture will be simply that… a picture. 

16. Click Cancel to close that screen without making a selection. 

17. In the Caption field, click the popup button. 

 

The Select Field screen is displayed.  

18. In the PT9\SAMPLES directory of your local People-Trak drive, select the file named 

PETE&PETUNIA.JPG.  

19. Add a Hyperlink object to the screen. 

20. In the Object Name field, click the popup button. 

 

As with the Button and Picture objects, you can select any button trigger. Typically a 

hyperlink is used to link to a website or another part of a document. In People-Trak, you 

can have it do any of the button trigger actions available. So, you have the choice of what 

you want your button to look like: a regular button (using the Button object), a picture 

(using the Picture object) or text underlined and in blue (using the Hyperlink object). 

21. Select any button trigger. 

 

The button trigger’s description is defaulted as the Caption but can be changed. 

22. In the Caption field, enter: This is what a hyperlink looks like. 

23. Open preview mode. 

 

The picture and hyperlink have been added to the screen and can be moved and resized as 

needed. The hyperlink uses the standard formatting of having the text in blue and 

underlined.  

 

This was just a quick look at the caption, line, picture and hyperlink objects to get you 

familiar with them. You can see that these objects allow you to create a very 

customizable screen.  

24. Close preview mode and close the Custom Screens screen, without saving your changes. 

25. This concludes this tutorial and lesson. 
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This lesson covers how to add and modify grids on your custom screen. 

Tutorials 
Adding a Grid: shows how to add a grid to your custom screen. 

Modifying a Grid in Preview Mode: demonstrates how to modify the grid in preview mode. 

Using Multiple Grids: demonstrates how to add another grid to your custom screen so you 

now have multiple grids on one screen. 
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Tutorial 5.1 – Adding a Grid 

A grid is added to a screen in two steps. The first step is to select a grid object and the second 

is to specify the fields that will make up the columns in the grid. Let’s do this now. 

1. On the Tools menu, select Custom Screens to start a new custom screen. Name the 

screen About Grids and leave it in the User category. Leave the Screen Type field set to 

Standard. 

2. In the Object Type column of the first row in the grid, click the popup button to display 

a list of the available objects. Select Grid as the object. 

3. Click the Preview button. 

 

Unfortunately, the following message is displayed: 

You have defined a grid with no fields. 

This message is just letting you know that you have only completed the first of two steps 

in creating a grid. You must not only specify a grid object, but you must also specify the 

fields that will become the columns on the grid. Let’s specify a field now. 

4. Click OK to close the message. 

5. In the second row in the grid, select the Field object. In the Object Name field, click the 

popup button to display a list of the available fields. Select the Last Name field from the 

Personal category.  

 

The following message is displayed: 

You cannot use a non-grid field within a grid. 

An employee only has one Last Name, so it will always be an individual field.  

6. Click OK to close the message. 

 

You can easily tell if a field is a non-grid field by looking at the row modifier popup 

options. A non-grid field will only have an option of 1. 

7. Use the popup button in the Object Name field to select the Property Type field from 

the Status category. 

 

The following message is displayed: 

 You cannot add a field to a grid where the grid name has not been specified. 

Ok, let’s fix that by specifying a grid name. First, we need to delete the field row that we 

are currently on. 

8. Click the Delete Row button on the Tool Bar. 

9. In the Object Name column of the Grid row, select the popup. 

The Container screen is displayed with the Grid container type object highlighted and a 

list of the available grids within Personnel Management listed. 
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10.  Select the Company Property grid and select OK. 

 

The Company Property grid and its fields are returned to the Objects grid. 

11. Now try to preview the grid again.  

 

This time it should work. Note that the number of rows is 10. 

12. Select the grid and press F1. 

13. Change the number of Height in Rows to 4 and click Apply to apply the change. Click 

anywhere off the grid to be able to see it again. 

 

You will see the number of rows in the grid change to 4. Note that the number of rows 

specified is not the total number of rows that are in the grid, but the total number of rows 

that will be displayed at one time. If there happen to be 16 rows available, the first four 

will be visible when the screen is initially displayed and the others can be shown using 

the scroll bars.  

 

Let’s put this new screen on a workflow and see what happens.  

14. Close the Custom Screens screen, saving your changes. Use what you have learned to 

add this new screen onto the Standard - Employee workflow. Make it the first screen, 

above Personal. Then open Donald Stern’s record and take a look at your screen.  

 

As you can see, Donald has been assigned several pieces of property. 

15. Close Donald Stern’s record and return to the About Grids screen you just created. 

Let’s add another field to the grid in the first available blank row. This time, pick the 

Dependent First Name field from the Personal category.  

 

The following message is displayed:  

You cannot mix fields in a grid from different grids. 

You were instructed incorrectly to select fields from two separate grids. A single grid 

cannot correctly store (and allow editing of) data from two different underlying database 

tables in People-Trak. In our example, we have attempted to juxtapose the Property Type 

field from the Company Property grid with the Dependent First Name field from the 

Dependents grid. While the report writer can actually do this and produce a reasonably 

meaningful result, the custom screens feature cannot. There is just no way to display and 

allow this data to be edited correctly. When you select fields for a grid on a custom 

screen, all of the fields in the grid must be from the same underlying table (normally 

indicated by coming from the same existing grid).  

16. Delete the Field row you just added. 

 

As you saw earlier, entering the grid name defaults all of the fields in that grid onto the 

custom screen grid. If you don’t want all these fields or want to rearrange them, you can 

do so. Let’s delete a field to demonstrate this. 

17. Delete the ID or Number row. When complete, use preview mode to take a look at the 

screen.  



Lesson 5 

 

44     Introduction to Custom Screens 

Tutorial 5.2 – Modifying a Grid in Preview Mode 

We currently have a four-column grid that is ready to be adjusted.  

1. Click on the grid to activate the grid for sizing. Now move the cursor to the right edge of 

the grid. When the cursor crosses the right edge, it will change to a left/right arrow. With 

the left/right arrow displayed, hold down the mouse button and carefully drag the right 

edge of the grid to the right. We do not want to move the grid; we want to make the grid 

wider. Drag the right edge about three-quarters of the way across the available space. 

Click off the grid to redisplay the grid image.  

 

The grid should now include all four columns. However, the fourth column is abnormally 

wide. That is because the last column in a grid automatically expands to fill the available 

space. We dragged the grid farther than necessary, so the column expanded. We can fix 

this by bringing the right edge of the grid back to the left.  

2. Drag the right edge back to the left. It might take a few tries.  

3. Click the grid, size it down and then click off the grid to check your progress. Repeat the 

process until the grid looks about right. If you bring the grid too far to the left, the last 

column will be too narrow or will disappear altogether. At this point, you should try to set 

the width of the last column, which is a date field, to the same width as the third column, 

which is also a date field. Remember, you can use the nudge keys if you wish. 

 

You can also size the grid vertically. Note that there are currently four rows in our grid. 

4. Use the mouse to drag the bottom of the grid down. Press F1 to see the properties for this 

object. 

 

The Height in Rows has been changed to the number of rows the grid now holds. It was 

automatically adjusted for you. 

 

The grid itself can also be moved using the same techniques used for moving other 

objects.  

5. Activate the grid by clicking on it and then use the mouse or the nudge keys to move the 

grid.  

 

You learned in earlier tutorials that you can set the display width of field objects. Well, 

this is also true for the column width of field objects used in grids. Here is how you do it. 

6. First, make certain that the grid itself has not been activated for movement. Now, click in 

the header area of the first column of the grid, which will highlight that header. Hover 

over the column separator line between the first and second column. The cursor will 

change to a left/right arrow. Click and hold the mouse button down and drag the column 

to the right. Release the button to check your results. You can click and drag and click 

and drag until the column is just the width you want. 

 

The grid itself is not automatically sized when you size a column. When you expand a 

column, space is taken from the last column to accommodate the change. Eventually, you 

may make the last column or even earlier columns invisible. If this happens, simply 

activate the grid for movement and expand (or contract) the grid as necessary. Normally, 

grid sizing goes hand in hand with column sizing.  
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7. Expand each of the columns in your grid. Note that the last column cannot be directly 

sized. You can only expand or contract the last column by sizing the grid itself. Continue 

until you have your grid sized satisfactorily. 

The expansion or contraction of the column width does not actually increase or decrease 

the number of characters or digits that can be entered. You can make a column such as 

the Property Type column, which is a 15-character field, as wide as you wish, but it will 

still only take 15 characters during data entry unless you use Screen/Field Customization 

to expand the capacity of the field itself. Let’s try this now. 

8. Expand the width of the Property Type column to something very large. Size the grid so 

that all four columns are still visible, even with a very wide Property Type column. 

Close preview mode. Close the Custom Screens screen, saving your changes. 

9. Open Donald Stern’s record. Select your About Grids custom screen. In the first blank 

row in the Property Type column, enter characters until no more characters are allowed. 

 

The default size of the Property Type field is 15 characters and it remains 15 characters 

regardless of how wide you make the column. You can increase the capacity of the 

column using something you have learned before. Keep reading for a refresher. 

10. Close Donald Stern’s record.  

11. On the Administration menu, select Screen/Field Customization.  

 

The Screen/Field Customization popup screen is displayed, which allows you to select 

the workflow to use for screen/field customization.  

12. Highlight Standard - Employee and click Customize to use that workflow for 

customization.    

 

The Standard - Employee workflow is displayed in customization mode with your custom 

screen showing. 

13. In the Property Type column, press the F1 key. Change the length of the field from 15 

to 50 characters. Close the Field Properties For: Property Type and Company 

Property screens, saving your changes. 

 

In the Field Customization process, changing a field will change it throughout all screens 

that include it. In this case, when you changed the Property Type field length (capacity) 

while on your custom screen, it also changed it on the base Company Property screen as 

well. Let’s check it out. 

14. Select the Status screen. Click the Property button. 

 

The Company Property screen is displayed. Note that the Property Type column is 50 

characters there as well. 

15. Close the Field Customization screen, saving your changes. 

16. Close Screen/Field Customization 

17. Open Donald Stern’s record again. Select your custom screen. In the Property Type 

field, enter characters until no more are allowed.  

 

This time, the capacity of the field and the physical size of the field match a little better. 
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This scenario remains the same if reversed. If you decrease the capacity of a field using 

the Screen/Field Customization process, the width of the field remains the same unless 

you change it with the Custom Screens process. Or, if you decrease the width of the field 

with the Custom Screens process, the capacity of the field is not decreased unless you do 

it manually using the Screen/Field Customization process. 

 

You cannot adjust row height or create multi-line rows. If you need to store more 

characters, you will need very wide columns. 

18. Close Donald Stern’s record. 

19. Continue with the next tutorial. 
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Tutorial 5.3 – Using Multiple Grids 

You can create more than one grid on a screen. We’ll update your latest custom screen to use 

two grids. 

1. On the Tools menu, select Custom Screens. Select the About Grids custom screen. 

 

As you learned earlier, you can define a grid by adding a grid object and specifying the 

name of the grid. The fields in that grid will then be automatically defaulted for you, and 

you can remove any that you do not want included. A grid is considered complete when 

there are no more field objects listed, or when an object other than a field object is added. 

So, to add a second grid to our sample screen, we need only add a grid object and specify 

the name of the grid. We are going to add some fields from the Dependents grid.  

2. In the first blank row, select a Grid object. In the Object Name column, use the popup to 

select the Dependents grid. 

 

All of the fields in the Dependents grid are added. Let’s just include the name fields in 

our grid on this screen. 

3. Use the Delete Row button to delete all but the following fields: 

 

Dependent First Name 

Dependent Middle Name 

Dependent Last Name 

4. Use preview mode to view our two grids. You might need to adjust grid location if they 

are overlapping. 

 

However, there are no overall grid headings to clarify the contents of the grid. We’ll fix 

that. 

5. Close preview mode. In the Caption column for the first Grid object, enter Company 

Property. In the Caption column for the second Grid object, enter Dependent 

Information. Now preview again. Again, you may need to do some tidying up to make 

things look right. 

 

This time, it is very obvious what information the respective grids contain. You can use a 

grid caption on any grid at any time. Normally, a caption is useful when there are two or 

more grids, or when a grid is mixed with stand-alone field objects. 

6.  Close preview mode. 

 

Let’s add one more grid. 

7. Add a Grid object in the first blank row and use the Object Name popup to select the 

Event History grid.  

 

The Event History grid is returned to the Objects grid. We will leave the fields alone. 

8. In the Caption field, enter Event History. 

9. Use preview mode to review the screen. 

 

As you can see, you have run out of room on the screen. You have two options when 
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using a Standard screen like we are: make the screen longer (which will turn on scrolling) 

or make the grids shorter. Let’s make the grids a bit shorter. 

10. Select the Dependent Information grid, press F1 and change the Height in Rows setting 

to a smaller number. Do the same for the Event History grid. Adjust as necessary to get 

all grids to fit on the screen. 

11. Close preview mode, saving your changes. 

 

Your screen provides information from three separate database tables displayed in three 

separate grids.  

12. Close the Custom Screens screen.  

 

It’s time to take a look at this thing. 

13. Open Donald Stern’s record. 

 

Wow! Look at all that information on your About Grids screen. Of course, there is some 

extra room and that means we could add one or more additional grids. We’ll skip that 

journey, but we have one more thing to learn. 

14. Close Donald Stern’s record and return to your About Grids custom screen. Note that 

the Captions for the three columns on the Property grid have backslashes (“\”) in them. 

Now, enter preview mode and see that these same columns have two line headings and 

that the height of the heading area is greater than on the other two grids. Also, the 

headings break at the position of the backslash character. 

15. Close preview mode and remove the backslash characters. Make sure you have at least 

one space between each word in the caption. Preview again.  

 

This time, all of the captions are single line. These single-line captions may or may not 

look better to you, but at least you now know how to control them. Add backslash 

characters and the captions break. Take out the backslash characters and the captions stay 

a single line. If just one column caption breaks, the entire heading will expand. (The 

single line captions are simply centered in the available space.) 

 

Multi-line captions are limited to two lines. If you add a second backslash character, it 

will be ignored and will simply become part of the heading. 

16. Close preview mode and close the Custom Screens screen.  

17. Use the Workflows process to update the Standard - Employee workflow. Remove the 

About Grids screen from the workflow. Close the Workflows screen. 

18. This concludes this tutorial and lesson. 
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This lesson covers even more features when working with custom screens. 

Tutorials 
Modify an Existing Screen: demonstrates how to use the Append Screen option to create a 

custom screen by appending screens and modifying them. 

Additional Screen Options: shows you how to use Insert Screen and frame features to create 

a custom screen by inserting screens and frames and modifying them. 

Create and Use a Template: demonstrates how to create a screen header template for use on 

multiple screens. 

Screen Objects as Tabs: demonstrates how to use screen objects as tabs to access the 

primary screens of all modules. 
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Tutorial 6.1 – Modify an Existing Screen 

One of the most common tasks you will perform with the Custom Screens process is 

modifying an existing screen. This is how you do it. 

1. On the Tools menu, select Custom Screens.  

2. On the File menu, select New Custom Screen or on the Tool Bar, click the New Custom 

Screen button to start a new custom screen. 

3. Change the name of this new screen to Personal with Photo. 

4. Leave the Category and Screen Type fields set to their defaults. 

5. On the File menu, select Append Screen. 

 

The Select Screen screen is displayed. 

6. Select the Personal screen.  

 

The objects that make up the Personal screen are loaded into the grid. Since we had 

nothing in our custom screen before this append, an insert would have accomplished the 

same result as we see now. An append adds the contents of the selected screen to the end 

of the current custom screen; an insert adds the contents of the selected screen at the 

current cursor location in the current custom screen. 

7. Scroll the list of objects and use the Delete Row button to delete the last two screen 

objects, ID and Communication. 

8. Click the Preview button to display the screen.  

 

You can see that our custom screen looks just like the standard Personal screen.  

 

A common request among some of our customers is to have the Employee Photo visible 

on the Personal screen. By default, we have placed the Employee Photo field on the ID 

screen along with the Employee Signature and Employee BarCode. However, if our 

customers want the photo on the Personal screen, they get it. 

First, we need to make some room for the photo by opening up space in the 

Demographics frame.  

9. Click on the Demographics frame to activate it. 

10. Drag the right edge of the frame to the right until it lines up with the right edge of the 

buttons just above. When the position looks good, click off the frame to deactivate the 

object.  

 

Now, we’ll add the photo. 

11. Close preview mode, saving your changes. Scroll the list of objects until you see the 

Disabled field (it is near the bottom of the list). Insert a blank row just after the Disabled 

field. 

12. In the Object Type column of the new blank row, select the Field object.  
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13. In the Object Name field, use the popup to select the Employee Photo Image field.  

 

Now we have to position the Employee Photo Image within the Demographics frame. 

14. Open preview mode.  

15. In the Object dropdown, select Field - Employee Photo Image. 

 

The Employee Photo field is activated and highlighted on the screen to the right.  

16. Drag the Employee Photo Image field onto the Demographics frame and arrange it as 

you see fit. Make sure to leave ample room on the left side of the photo for the 

Select/Clear Image buttons. Close preview mode, saving your changes. 

17. Close the Custom Screens screen, saving your changes. 

18. On the Tools menu, select Workflows. On the Tool Bar, click the New Workflow button 

to create a new workflow. Change the Workflow Name to New Personal Screen. Leave 

the Show on Menu check box selected so that this workflow will show up on the 

Workflows menu.  

 

We need to add your new screen to the workflow.  

19. Click the Screens tab. In the Screen Name field, click the popup button to display a list 

of the available screens. Select the Personal with Photo screen. Close the Workflows 

screen, saving your changes.  

 

We now have a workflow with your screen. 

20. Open the Workflows menu. Select the New Personal Screen workflow and open 

Donald Stern’s record. 

 

Note that all of his information including his photo is displayed in your new screen.  

21. Close the record. 

 

That is a simple, single-screen workflow using your customized personal screen. 

22. Continue with the next tutorial. 
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Tutorial 6.2 – Additional Screen Options 

In an earlier lesson, we created a simple screen from scratch by adding frame objects and 

selecting individual fields. We also mentioned that we would get fancier and use the Object 

Name column with frames in later training. The time has come! 

1. On the Tools menu, select Custom Screens.  

2. On the File menu, select New Custom Screen or on the Tool Bar, click the New Custom 

Screen button to start a new custom screen. 

3. In the first row of the Object Type column, select a Frame object. 

4. In the Object Name column, click the popup button.  

This time, the Container screen is displayed with two container object types to choose 

from: Frame and Grid. Frame is highlighted and a list of the available frames within 

Personnel Management is available to select from. Since we will be choosing a frame for 

our screen, we can leave Frame highlighted. 

5. Select the ID and Name frame and select OK. 

6. In the first row of the Object Type column, select a Frame object. 

7. In the next blank row, add another Frame object 

8. In the Object Name column, click the popup button and select the Address frame. 

9. Preview your screen. 

 

That’s it. You can create a small screen from existing frames in just a few minutes. But 

that’s not all you can do. You can put frames from different screens together for your 

own customized screen and append and insert different screens as well. Let’s use a few of 

these screen features to create a hybrid of the Personal screen and the Status screen. 

10. Close preview mode. 

11. On the File menu, select Append Screen to append the Status screen to the bottom of 

your working screen. 

12. Use preview mode to take a look at your screen.  

 

You can actually use this screen in a workflow. The vertical scroll bars will be activated 

and you will be able to scroll the screen up and down when it is displayed.  

13. Close preview mode. 

 

Now let’s use the Insert Screen option, which allows you to insert an existing screen 

anywhere you choose in your custom screen. Let’s try this. 

14. Position the cursor to the top of the Status screen (there will be a frame labeled Current 

Status).  

 

This is where we are going to insert another screen. 
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15. On the File menu, select Insert Screen and insert the Company Property screen into the 

location specified. 

16. Use preview mode to confirm the results.  

17. Close preview mode, delete this screen, and close the Custom Screens screen. 

18. Continue with the next tutorial. 
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Tutorial 6.3 – Create and Use a Template 

Over the years, we have had many requests to have workflows that repeat certain information 

at the top of each screen. For example, some users would like to repeat the job code or 

department code or location code or all of the above at the top of each screen. Of course, this 

is information above and beyond the information we already show. This is now something we 

can show you how to do. 

1. Create a new custom screen. Name the screen Screen Header and put it in the Personal 

category. Leave the Screen Type field set to Standard. 

2. Add a Frame object and set the Caption to Header Information. 

3. Add the following Fields: 

 

Job Code 

Job Title 

Department Code 

Department Name 

4. Use preview mode to align the fields toward the top of the frame as shown below: 

 

Job Code   Department Code 

Job Title   Department Name 

5. Drag the frame up so that you have a nice, tidy standard header. This is your new screen 

header template. Close preview mode and save your screen.  

 

Now, let’s use this template. 

6. Create a new custom screen. Name the screen New Personal and put it in the Personal 

category. Leave the Screen Type field set to Standard. 

7. Use the Append Screen option to append your Screen Header screen to the current 

custom screen. Then use the Append Screen option again to append the Personal screen.  

8. Use preview mode to confirm that you now have a Personal screen with a standard 

screen header. Save your new screen. 

9. Create a new custom screen. Name the screen New Status and put it in the Status 

category. Leave the Screen Type field set to Standard. 

10. Use the Append Screen option to append your Screen Header screen to the current 

custom screen. Then use the Append Screen option again to append the Status screen.  

11. Use preview mode to confirm the screen. Close the Custom Screens screen. 

 

We could repeat this step for each of the ten main screens in the Personnel module, but 

we won’t. 

12. Use the Workflows process to update the Standard - Employee workflow. Put your 

New Personal screen and your New Status screen in place of the standard screens. Close 

the Workflows screen, saving your changes. 



Custom Screens 6: More Features 

 

 Introduction to Custom Screens     55 
 

13. Open Donald Stern’s record within the Standard - Employee workflow. 

 

Note that the New Personal and New Status screens exhibit the standard screen header 

that you have created. (The other screens do not, because we did not put the header 

there.) 

 

Now, the New Personal and New Status screens are a bit long and require scrolling, but 

anyone who knows how to tweak a screen can fix that. You can try that another time. 

14. Close Donald’s record. 

15. Use the Workflows process to update the Standard - Employee workflow. Replace your 

New Personal and New Status screens with the standard screens. Close the Workflows 

screen, saving your changes. 

16. Continue with the next tutorial. 
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Tutorial 6.4 – Screen Objects as Tabs 

Another question we sometimes receive is whether we have the ability to arrange all of the 

first level screens in a module in tabs. Technically, we are not fond of tabs when you need 

more than one row. As there are 11 screens in the Personnel module, we have decided not to 

utilize tabs, but continue to provide a dropdown to select screens. However, you can use 

buttons to simulate a tab-based interface. Here is how to do it. 

1. Create a new custom screen.  Name it Tab Interface and put it in the Personal category. 

Leave the Screen Type field set to Standard. 

2. Add a Frame object and then the following Fields: 

 

Employee ID 

Full Name 

Hire Date 

Job Code 

Job Title 

3. Use preview mode to align the fields to the top of the screen so that they are easy to read. 

This is the new screen header. Close preview mode. 

 

At this point, you would want to add screen objects for every primary screen. To save 

you some time, we will do just the first three. 

4. Add Screen objects for the Personal (EMP-1), Status (EMP-2) and Compensation 

(EMP-3) screens. 

5. Use preview mode to size the buttons to the same height and width. Then align the 

buttons into a row just below the screen header. Remember to use the alignment tools to 

make your life easier. If you were doing a button for every primary screen, you could 

stagger the buttons a little or use any technique you desire to simulate a tab-based 

interface. 

6. Close preview mode. Close the Custom Screens screen, saving your changes. 

7. Use the Workflows process to insert this screen into the Standard - Employee workflow 

as the first screen. (Normally, this powerful screen would be a single-screen workflow, 

but we’ll learn about that later.) Close the Workflows screen, saving your changes. 

8. Open Donald Stern’s record.  

 

The fields on the header are populated and you should have an array of buttons that will 

allow you to display any screen within the Personnel module with a single click. Try it.  

9. Display the Personal screen and close it. Then display the Status screen and close it. 

Display them all if you wish. 

 

The whole point is that everything is in one place with a header that lets us know what 

record we are working on. 

 

Of course, you could add or subtract fields from the header. Or you could align the 

buttons vertically. Or you could take the Personal screen and simply align all of the other 

screens vertically on the far right side and have a single screen with buttons (or tabs) to 

get to any other screen. 
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10. Close Donald’s record. 

11. Exit People-Trak. 

12. This concludes this tutorial and lesson.  

 

 

 


